Page 1 of 1

Error Build Surface

PostPosted: Wed Nov 15, 2017 6:01 am
by tinus
Hi,

I just installed the new version of Mango (4.0.1).
However, I can't build a surface:

"Error: edu.uthscsa.ric.mango.viewersurface.SurfaceViewer.<init>(SurfaceViewer.java:456) [com.jogamp.common.util.PropertyAccess.isPropertyDefined(Ljava/lang/String;Z)Z]"

Any suggestions?
I tried to use the search field in the forum, but it doesn't work:
"error build surface" seems to have too common words....???

Gr.
Martijn

Re: Error Build Surface

PostPosted: Wed Nov 15, 2017 6:29 pm
by admin
What operating system are you using?

Re: Error Build Surface

PostPosted: Thu Nov 16, 2017 3:49 am
by tinus
Sorry, forgot about that:
Mac OS 10.11.6
Java: 8.151

I tried the Mango's beta version here: http://rii.uthscsa.edu/mango/beta.html
Still same error.

I also tried the webapp surface test, which is also not working.
The sandbox version seem to work as well as the papaya test.
Not sure whether this is useful info?

Best,
Martijn

Re: Error Build Surface

PostPosted: Thu Nov 16, 2017 7:43 am
by admin
I was thinking you were using some version of Linux and there may be a library issue. I tested in Mac OS 10.11.6 and had no issues.

The error message is about basic OpenGL support. Have you made any changes in your operating system related to 3D support?

You might try going to Options > Preferences > Display > OpenGL in Mango and selected "Default Graphics". Restarting Mango and try again.

Another thought is perhaps, especially if you upgraded from a very old version, that there is some conflict with old application files. You can try to go /Users/<username>/Library/Application Support/Mango. If possible, delete the entire Mango folder there. You would lose any plugins you've loaded, so if you want to keep them, just copy that directory elsewhere. Be sure to close Mango before removing that folder, then restart it and try again.

Re: Error Build Surface

PostPosted: Fri Nov 17, 2017 3:59 am
by tinus
hmm... too bad, both your suggestions didn't work.

I'm not sure whether I changed anything related to OpenGL actually.
I've installed Slicer, some Matlab related OpenGL stuff, DIPimage/DIPlib

Re: Error Build Surface

PostPosted: Mon Jan 15, 2018 11:05 pm
by malbert
I have the same error with OSX also.
I believe that the problem is more related to the video card. The same version of Mango works nicely on a macbook pro and not on a mac pro (with a mirror drive for both machines). Surprisingly, mango surface is working on windows running on a virtual machine on a computer that does not run the surface option natively.